Linux botnet Mayhem spreads through Shellshock exploits

The botnet targets Web servers that haven't been patched for recent vulnerabilities found in the Bash Linux shell

Shellshock continues to reverberate: Attackers are exploiting recently discovered vulnerabilities in the Bash command-line interpreter in order to infect Linux servers with a sophisticated malware program known as Mayhem.

Mayhem was discovered earlier this year and was thoroughly analyzed by researchers from Russian Internet firm Yandex. It gets installed through a PHP script that attackers upload on servers via compromised FTP passwords, website vulnerabilities or brute-forced site administration credentials.

Mayhem's main component is a malicious ELF (Executable and Linkable Format) library file that, after installation, downloads additional plug-ins and stores them in a hidden and encrypted file system. The plug-ins enable attackers to use the newly infected servers to attack and compromise additional sites.

In July, the Yandex researchers estimated that the botnet consisted of around 1,400 infected servers that connected to two separate command-and-control servers.

Researchers from independent research outfit Malware Must Die (MMD) reported earlier this week that Mayhem's authors have added Shellshock exploits to the botnet's arsenal.

Shellshock is the collective name for several vulnerabilities discovered recently in the Linux Bash command-line interpreter. They can be exploited to achieve remote code execution on servers through several attack vectors including the CGI (Common Gateway Interface), OpenSSH, DHCP (Dynamic Host Configuration Protocol) and even OpenVPN in some cases.

The Shellshock attacks originating from the Mayhem botnet target Web servers with CGI support. The bots probe Web servers to determine if they're vulnerable to the Bash flaws and then exploit them to execute a Perl script, according to the MMD researchers.

The script has the malicious Mayhem ELF binary files for both 32-bit and 64-bit CPU architectures embedded into it as hexadecimal data and uses the LD_PRELOAD function to extract and run them on the system, the researchers said in a blog post.

Like the previous version, it creates a hidden file system where it stores its additional components -- plug-ins -- that are used for various types of scanning and attacks against other servers. The MDL researchers suspect that one of those components has been updated to use the new Shellshock exploits, but haven't confirmed it yet.

However, this theory is supported by the fact that some of the observed Shellshock attack attempts have originated from IP (Internet Protocol) addresses associated with existing Mayhem bots in addition to new IP addresses from a variety of countries including the U.K., Indonesia, Poland, Austria, Australia and Sweden. MMD has shared the information it has gathered with national computer emergency response teams (CERTs).

Most Linux distributions have issued patches for the Shellshock vulnerabilities already, but many Web servers, especially self-managed ones, are not configured to deploy updates automatically. There are also many Linux-based enterprise products and embedded devices that include Web servers and are vulnerable to Shellshock. These can also be a target if patches for them haven't been deployed or are not yet available.

Join the TechWorld newsletter!

Error: Please check your email address.

Tags patchessecurityMalware Must DieExploits / vulnerabilitiesmalwareYandex

More about CGIGatewayLinux

Show Comments