VBulletin resets patches and issues emergency patches following breach

Evidence suggests that hackers had access to at least one zero-day exploit

VBulletin Solutions has reset the passwords for over 300,000 accounts on its website following a security breach, and also released emergency security patches. The company's Internet forum software is used on tens of thousands of websites.

It's not clear if the patches were prompted by the security breach, but the hacker who claimed to have compromised the vBulletin.com database put a zero-day vBulletin exploit -- an exploit for an unpatched vulnerability -- up for sale on Monday.

VBulletin Solutions did not immediately respond to an inquiry seeking more details about the patches and their relationship to the breach.

The company says that more than 100,000 community websites are using vBulletin, including some operated by Zynga, Electronic Arts, Sony Pictures, NASA, Valve Corporation and other well known companies and organizations.

Patches were released for vBulletin versions 5.1.4 to 5.1.9 after someone reported a security issue to the company, vBulletin Solutions said in an advisory published Monday.

The company advised all users to update their installations as soon as possible.

On Saturday, someone using the online handle Coldzer0 claimed on various websites that he compromised vBulletin.com and extracted information on almost 480,000 users from its database. The user also claimed to have hacked the support forum of Foxit Software, which uses vBulletin.

The vBulletin.com forum has 344,629 members, according to statistics displayed on the site. This number doesn't match the one claimed by the hacker, but it's possible that for some reason more user entries existed in the site's database.

On Monday, a listing for a "vBulletin 5.x.x Remote Code Execution 0day Exploit" appeared on a website that specializes in exploit sales. The listing was posted by a user named Coldzer0.

Tuesday, after vBulletin released its patches, a Twitter user using the handle @_cutz published the details of a remote code execution flaw in vBulletin that supposedly has existed for the past three years. Cutz published the details because "it's fixed now anyway."

It's not clear whether the vBulletin patches address the vulnerability exploited by Coldzer0 or the one disclosed by _cutz, or if they're the same flaw. But regardless, the administrators of vBulletin-based forums should deploy the patches immediately because the likelihood of attacks is high.

Join the TechWorld newsletter!

Error: Please check your email address.

More about Foxit SoftwareNASASonyTwitterZynga

Show Comments
[]