Cisco patches serious flaws in cable modems and home gateways

The vulnerabilities could lead to remote code execution, information disclosure or denial of service

Cisco Systems has patched high-impact vulnerabilities in several of its cable modem and residential gateway devices that are distributed by some ISPs to their customers.

The embedded Web server in the Cisco Cable Modem with Digital Voice models DPC2203 and EPC2203 contains a buffer overflow vulnerability that can be exploited remotely without authentication.

The flaw could be exploited by sending specially crafted HTTP requests to the Web server and could result in arbitrary code execution.

Customers should contact their service providers to ensure that the software version installed on their devices includes the patch for this issue, Cisco said in an advisory.

The Web-based administration interfaces of the Cisco DPC3941 Wireless Residential Gateway with Digital Voice and Cisco DPC3939B Wireless Residential Voice Gateway are affected by a vulnerability that could lead to information disclosure.

An unauthenticated, remote attacker could exploit the flaw by sending a specially crafted HTTP request to an affected device in order to obtain sensitive information from it.

The Cisco Model DPQ3925 8x4 DOCSIS 3.0 Wireless Residential Gateway with EDVA is affected by a separate vulnerability, also triggered by malicious HTTP requests, that could lead to a denial-of-service condition.

In recent years, attackers have increasingly targeted modems, routers and other gateway devices, especially those distributed by ISPs to their customers. By compromising such devices, attackers can snoop on, hijack or disrupt network traffic or can attack other devices inside local networks.

Join the TechWorld newsletter!

Error: Please check your email address.

More about CiscoCustomersGateway

Show Comments

Market Place

[]